Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 19

Thema: »libQtGui.so.4«-Fehler unter Ubuntu 20.04 kann nicht gelöst werden

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Member
    Registriert seit
    May 2006
    Beiträge
    353

    Unhappy »libQtGui.so.4«-Fehler unter Ubuntu 20.04 kann nicht gelöst werden

    Bei meiner alten Ubuntu-Version 19.10 konnte ich problemlos in der Konsole den Decoder mit
    Code:
    qotr
    aufrufen, doch nun wird mir die Fehlermeldung
    Code:
    qotr: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
    angezeigt. Ein anderer Nutzer konnte dies lösen, indem er
    Code:
    sudo apt-get install libqtgui4:i386
    eingegeben hat, um somit die 32-bit-Version von libqtgui4 nachzuinstallieren. Dies habe ich ebenfalls versucht, doch dann diese Meldung zurückbekommen:

    Code:
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Paket libqtgui4:i386 ist nicht verfügbar, wird aber von einem anderen Paket
    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
    wurde oder nur aus einer anderen Quelle verfügbar ist.
    
    E: Für Paket »libqtgui4:i386« existiert kein Installationskandidat.
    Das heißt, es hat nicht geklappt und das Eingeben von
    Code:
    qotr
    in der Konsole bringt immer noch dieselbe Fehlermeldung.

    Was kann man tun, um das zu lösen?

  2. #2
    Administrator
    Registriert seit
    Jan 2007
    Beiträge
    4.017
    Hallo Rude,

    ich kenne mich leider bei Ubuntu nicht so wirklich gut aus (ich nutze arch und OpenSuse), aber vielleicht hilft dir das Paket weiter, das hier zum DL angeboten wird: https://packages.ubuntu.com/bionic/libqtgui4 (Links zum DL sind unten auf der Seite). Das könntest du dann von Hand installieren.

    EDIT:

    Hab gerade nochmal geschaut, da Ubuntu ja auf Debian aufbaut, könnte es das Paket auch für Standard-Debian geben und von dir händisch eingepflegt werden. Die Debian-Variante steht unter /etc/debian_version, und Debian Pakete findet man z. B. hier: https://packages.debian.org/search?keywords=libqtgui4
    Gruß
    PeGu

  3. #3
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Das Paket von hier lässt sich ja leider nicht installieren, auch dann nicht, wenn man
    Code:
    sudo apt-get install libqtgui4
    statt
    Code:
    sudo apt-get install libqtgui4:i386
    eingibt. Da kommt dann wieder dieselbe Fehlermeldung.

    Wie man das Debian-Paket installieren könnte, weiß ich leider nicht.

  4. #4
    Administrator
    Registriert seit
    Jan 2007
    Beiträge
    4.017
    Leider bin ich momentan da auch mit meinem Latein am Ende, weil ich ja leider kein Debian / Ubuntu-User bin. Ich verstehe nicht, wieso dpkg da offensichtlich die libsm6 nicht ignoriert. Hm.
    Das Warnschild etc. kommt sicherlich von deiner "normalen" Paketverwaltung, die dein System im Hintergrund pflegt. Die hat gemerkt, dass du da versuchst, etwas zu installieren, das Abhängigkeiten verletzt. Beim nächsten normalen Update bzw. bei der nächsten normalen Pflege deines Systems dürfte da soweit alles wieder im grünen Bereich liegen, außer Probieren ist ja nichts passiert. Dieses Probieren ist aber natürlich in Datenbanken und Caches geschrieben worden.

    Sorry, ich wär jetzt gerne viel hilfreicher, muss aber zugeben, dass mir gerade nichts mehr einfällt. Ich versuche mich schlauer zu machen.
    Gruß
    PeGu

  5. #5
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Ok. Danke auf jeden Fall für die Hilfe bei den bisherigen Versuchen. Vielleicht kann jemand dieses Problem ja lösen. Das Thema wurde schon oft angeklickt und scheint mehrere Leute zu interessieren.

  6. #6
    Member
    Registriert seit
    Dec 2009
    Ort
    Germany
    Beiträge
    161
    @onlinetvrecorder.com:
    Es ist Eure Aufgabe dieses Problem aus der Welt zu schaffen: Schreibt die GUI neu für Qt5.


    Bis dahin:
    easydecoder-gui-deps.tar.gz herunterladen, entpacken und die enthaltenen Dateien in das Verzeichnis des easydecoder kopieren.
    Falls das deb-Paket installiert wurde, kopiert die Dateien in das Verzeichnis /usr/lib/qotrdecoder

    Dann sollte qotr starten. Dekodieren habe ich nicht getestet.
    Geändert von loretotr (01.07.2020 um 07:13 Uhr)

  7. #7
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Wird da nun an einer Lösung gearbeitet? Wenn ja: Wann können wir mit ihr rechnen?

  8. #8
    Administrator
    Registriert seit
    Jan 2007
    Beiträge
    4.017
    Hallo Rude,

    bis hier ein anderer Ubuntu-Nutzer sicher viel kompetenter ist, probiere ich mal zu helfen mit UN*X Allgemein und dem, was ich von Ubuntu gelesen habe.

    Eigentlich sollte es so einfach sein wie: Debian-Paket (*.deb) runterladen, dann im Dateimanager entweder einfach Doppeklicken oder Rechtsklick -> Öffnen mit ... -> Paketverwaltung / Softwareverwaltung . Dann müsste dein ganz normales Softwareverwaltungstool das "Fremdpaket" installieren.

    Alternativ gibt es eine Ubuntu-Oberfläche fürs Einspielen von "Fremdpaketen", gdebi, das du über
    Code:
    sudo apt install gdebi
    bekommst. Dort dann in der grafischen Oberfläche das oben runtergeladene *.deb auswählen.

    Wenn alle Stricke reißen und du von der Command LIne installieren willst, dann lädtst du ebenfalls das *.deb runter (nennen wir es fürs Beispiel libqtgui.deb). Dann:

    Code:
    sudo apt install /full/path/to/libqtgui.deb
    (z. B. sudo apt install ~/Downloads/libqtgui.deb)
    oder
    Code:
    sudo dpkg -i ~/dibqtgui.deb
    "Fremdpaket" klingt nicht so schön, es ist aber doch das schöne in der UN*X-Welt, dass wir grundsätzlich uns gegenseitig alles zur Verfügung stellen können, manchmal mit mehr, manchmal mit weniger Veränderung im Paket. Und Debian-Pakete dürften auf Ubuntu ohne Veränderung auskommen.
    Gruß
    PeGu

  9. #9
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Ich habe es mit dem Paket
    Code:
    libqtgui4_4.8.7+dfsg-18_i386.deb
    versucht und
    Code:
    sudo apt install ~/Downloads/libqtgui4_4.8.7+dfsg-18_i386.deb
    eingegeben.

    Das hier kam als Rückmeldung:
    Code:
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    Hinweis: »libqtgui4:i386« wird an Stelle von »/home/username/Downloads/libqtgui4_4.8.7+dfsg-18_i386.deb« gewählt.
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
    
    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
     libqtgui4:i386 : Hängt ab von: libjpeg62-turbo:i386 (>= 1.3.1) ist aber nicht installierbar
                      Hängt ab von: libmng1:i386 (>= 1.0.10) ist aber nicht installierbar
                      Hängt ab von: libqtcore4:i386 (= 4:4.8.7+dfsg-18) ist aber nicht installierbar
                      Empfiehlt: qt-at-spi:i386 ist aber nicht installierbar
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

  10. #10
    Administrator
    Registriert seit
    Jan 2007
    Beiträge
    4.017
    Hallo Rude,

    dann kommen wir doch der Sache langsam näher. So blöd Fehlermeldungen in dem Moment sind, wo man eigentlich eine Erfolgsmeldung haben möchte, so hilfreich sind sie doch.

    Jetzt wissen wir, dass dein System die libQtGui nicht installieren möchte, weil Abhängigkeiten fehlen. Diese Abhängigkeiten kann es offensichtlich selbst nicht lösen und macht sinnvollerweise erst einmal nichts.

    Du müsstest probieren, ob es ausreicht, libqtgui "nackt", also ohne seine Abhängigkeiten zu installieren. Das müsste (sorry, hab gerade kein Debian-System zum ausprobieren zur Hand) so gehen:

    Code:
    sudo apt install --nodeps ~/Downloads/libqtgui4_4.8.7+dfsg-18_i386.deb
    Notfalls bitte man apt und nachschauen, wie die "do not install dependencies" Option aussieht, wenn nicht --nodeps.

    Problematisch sind die drei Pakete, die als "Hängt ab von..." aufgeführt sind, das empfohlene Paket kannst du vergessen, das macht nichts.

    Hast du gdebi schon probiert, das, soweit ich das verstanden habe, ja gerade zum Auflösen von Abhängigkeiten entwickelt wurde (ich weiß aber nicht, ob es die Abhängigkeiten über die Grenzen der eigenen aktuellen Repositories anbietet aufzulösen, oder ob du die drei Abhängigkeiten ebenfalls als "Fremdpaket" laden und installieren musst.
    Gruß
    PeGu

Seite 1 von 2 12 LetzteLetzte

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •