Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: »libQtGui.so.4«-Fehler unter Ubuntu 20.04 kann nicht gelöst werden

  1. #11
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Das hat leider auch nicht geklappt. Das Eingeben von
    Code:
    sudo dpkg --ignore-depends=libjpeg62-turbo,libmng1,libqtcore4,libsm6 -i ~/Downloads/libqtgui4_4.8.7+dfsg-18_i386.deb
    führte zu diesen Meldungen:

    Code:
    (Lese Datenbank ... 413982 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von .../libqtgui4_4.8.7+dfsg-18_i386.deb ...
    Entpacken von libqtgui4:i386 (4:4.8.7+dfsg-18) über (4:4.8.7+dfsg-18) ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libqtgui4:i386:
     libqtgui4:i386 hängt ab von libaudio2.
     libqtgui4:i386 hängt ab von libice6 (>= 1:1.0.0).
     libqtgui4:i386 hängt ab von libjpeg62-turbo (>= 1.3.1).
     libqtgui4:i386 hängt ab von libmng1 (>= 1.0.10).
     libqtgui4:i386 hängt ab von libqtcore4 (= 4:4.8.7+dfsg-18); aber:
      Paket libqtcore4:i386 ist nicht installiert.
     libqtgui4:i386 hängt ab von libsm6; aber:
    
    dpkg: Fehler beim Bearbeiten des Paketes libqtgui4:i386 (--install):
     Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Trigger für libc-bin (2.31-0ubuntu9) werden verarbeitet ...
    Fehler traten auf beim Bearbeiten von:
     libqtgui4:i386
    Zusätzlich ist bei mir in der oberen Leiste seit der Eingabe von
    Code:
    sudo dpkg --ignore-depends=libjpeg62-turbo,libmng1,libqtcore4 -i ~/Downloads/libqtgui4_4.8.7+dfsg-18_i386.deb
    ein Warnschild erschienen, das dem Warnschild vor einer Einbahnstraße gleicht. Wenn ich dort draufklicke, öffnet sich unterhalb eine Sprechblase, in der das Folgende steht:

    Ein Fehler ist aufgetreten, bitte starten Sie die Paketverwaltung über das Kontextmenü oder führen Sie in einem Terminal »apt-get« aus, um das Problem zu untersuchen. Die Fehlermeldung war: »Fehler: BrokenCount > 0«. Dies bedeutet in der Regel, dass die Abhängigkeiten von installierten Paketen nicht erfüllt werden können.
    Danach kann ich auf eine Schaltfläche namens „Verfügbare Aktualisierungen anzeigen“ klicken. Darunter befindet sich eine weitere Schaltfläche mit „Hinweise anzeigen“, vor die ein Haken gesetzt ist. Ganz unten befindet sich noch eine Schaltfläche mit der Bezeichnung „Einstellungen“.
    Geändert von Rude (30.06.2020 um 21:25 Uhr)

  2. #12
    Administrator
    Registriert seit
    Jan 2007
    Beiträge
    3.954
    Leider bin ich momentan da auch mit meinem Latein am Ende, weil ich ja leider kein Debian / Ubuntu-User bin. Ich verstehe nicht, wieso dpkg da offensichtlich die libsm6 nicht ignoriert. Hm.
    Das Warnschild etc. kommt sicherlich von deiner "normalen" Paketverwaltung, die dein System im Hintergrund pflegt. Die hat gemerkt, dass du da versuchst, etwas zu installieren, das Abhängigkeiten verletzt. Beim nächsten normalen Update bzw. bei der nächsten normalen Pflege deines Systems dürfte da soweit alles wieder im grünen Bereich liegen, außer Probieren ist ja nichts passiert. Dieses Probieren ist aber natürlich in Datenbanken und Caches geschrieben worden.

    Sorry, ich wär jetzt gerne viel hilfreicher, muss aber zugeben, dass mir gerade nichts mehr einfällt. Ich versuche mich schlauer zu machen.
    Gruß
    PeGu

  3. #13
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Ok. Danke auf jeden Fall für die Hilfe bei den bisherigen Versuchen. Vielleicht kann jemand dieses Problem ja lösen. Das Thema wurde schon oft angeklickt und scheint mehrere Leute zu interessieren.

  4. #14
    Member
    Registriert seit
    Dec 2009
    Ort
    Germany
    Beiträge
    147
    @onlinetvrecorder.com:
    Es ist Eure Aufgabe dieses Problem aus der Welt zu schaffen: Schreibt die GUI neu für Qt5.


    Bis dahin:
    easydecoder-gui-deps.tar.gz herunterladen, entpacken und die enthaltenen Dateien in das Verzeichnis des easydecoder kopieren.
    Falls das deb-Paket installiert wurde, kopiert die Dateien in das Verzeichnis /usr/lib/qotrdecoder

    Dann sollte qotr starten. Dekodieren habe ich nicht getestet.
    Geändert von loretotr (01.07.2020 um 06:13 Uhr)
    Installation und Updates otr-verwaltung3p: Schneiden von OTR-Dateien, inkl. Dekodieren und Verwalten
    Mein github Name ist gCurse. Ich bin der Maintainer der otr-verwaltung3p.

  5. #15
    Member
    Registriert seit
    May 2006
    Beiträge
    353
    Wird da nun an einer Lösung gearbeitet? Wenn ja: Wann können wir mit ihr rechnen?

  6. #16
    Administrator
    Registriert seit
    Jan 2007
    Beiträge
    3.954
    Hallo,

    leider kann ich hier noch nichts Neues sagen, ich habe aber nachgefragt, was den Stand der Linux-Entwicklung angeht. Sobald ich was weiß, melde ich mich hier nochmal.
    Gruß
    PeGu

  7. #17
    Administrator
    Registriert seit
    Jan 2019
    Beiträge
    35
    Hallo,

    kann da leider so direkt (Neuprogrammierung) nicht weiterhelfen, aber wir haben eine Lösung für Linux Mint bekommen, die sollte auch für Ubuntu funktionieren:
    Aus der hier angegebenen ppa-Quelle (ppa:nrbrtx/python2-stuff) die alten Python libs über den Paketmanager installieren, also die alten Libs (wie in der Readme angegeben) installieren:
    https://launchpad.net/~nrbrtx/+archi.../python2-stuff

    Hoffe das hilft zumindest mal vorübergehend weiter.

Seite 2 von 2 ErsteErste 12

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •