Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Test erfolgreich, FTP-Push funktioniert trotzdem nicht

  1. #1
    Member
    Registriert seit
    Apr 2018
    Beiträge
    9

    Test erfolgreich, FTP-Push funktioniert trotzdem nicht

    Moin,

    ich habe mir heute den Premium-Status gekauft, um das FTP-Push-Feature nutzen zu können.
    Der Test verlief auch erfolgreich, doch leider scheint irgendetwas nicht ganz zu funktionieren.

    Ich habe eine Datei hinzugefügt und mittlerweile steht bei den Versuchen eine 3 und nichts passiert mehr (https://www.onlinetvrecorder.com/v2/ftp/). Woran kann das liegen?
    Wie viele Ports müssen denn für das passive FTP offen sein?...

    Benutzername bei OTR: mark-s

    Danke schonmal im Voraus

    Viele Grüße
    Mark
    Geändert von mschmale (15.09.2019 um 06:47 Uhr)

  2. #2
    Moderator im Ruhestand
    Registriert seit
    Jul 2006
    Beiträge
    12.792
    Hi,

    für den gezielten Support ist deine OTR-ID (Konto-Id) nötig. Die findest du auf folgender Seite: https://www.onlinetvrecorder.com/v2/account/accountdata

  3. #3
    Member
    Registriert seit
    Apr 2018
    Beiträge
    9
    Zitat Zitat von Cineatic Beitrag anzeigen
    Hi,

    für den gezielten Support ist deine OTR-ID (Konto-Id) nötig. Die findest du auf folgender Seite: https://www.onlinetvrecorder.com/v2/account/accountdata
    Konto-Id: 2291900

  4. #4
    Member
    Registriert seit
    Jul 2018
    Beiträge
    7
    Da es bitte hier 'weitergeht':
    • deaktiviere in den Einstellungen auf onlinetvrecorder.com das passiven FTP.
    • erstelle in Deinem Router eine Portweiterleitung vom in onlinetvrecorder.com eingestellten Port zum Port des FTP-Servers. Protokoll: TCP.
    • erlaube in der Firewall des FTP-Servers (und auch in denen vor dem FTP-Server), daß TCP-Verkehr auf diesem Port angenommen wird.
    • sorge dafür, daß der in onlinetvrecorder.com gespeicherte Username/Paßwort auf dem FTP-Server vorhanden und aktiv ist.
    • sorge dafür, daß das in onlinetvrecorder.com konfigurierte Unterverzeichnis durch diesen Benutzer beschrieben werden kann.

    Klappt's?

  5. #5
    Member
    Registriert seit
    Apr 2018
    Beiträge
    9
    Zitat Zitat von cthom Beitrag anzeigen
    Da es bitte hier 'weitergeht':
    • deaktiviere in den Einstellungen auf onlinetvrecorder.com das passiven FTP.
    • erstelle in Deinem Router eine Portweiterleitung vom in onlinetvrecorder.com eingestellten Port zum Port des FTP-Servers. Protokoll: TCP.
    • erlaube in der Firewall des FTP-Servers (und auch in denen vor dem FTP-Server), daß TCP-Verkehr auf diesem Port angenommen wird.
    • sorge dafür, daß der in onlinetvrecorder.com gespeicherte Username/Paßwort auf dem FTP-Server vorhanden und aktiv ist.
    • sorge dafür, daß das in onlinetvrecorder.com konfigurierte Unterverzeichnis durch diesen Benutzer beschrieben werden kann.

    Klappt's?
    Danke erstmal für die Antwort.

    Leider scheint irgendetwas nicht richtig zu funktionieren. Also ich nutze eine Synology DiskStation... und da habe ich keine Möglichkeit gefunden, aktives FTP explizit zu aktivieren. Habe daher einfach mal geguckt, welche Ports für aktives FTP benötigt werden und daher zusätzlich zu Port 21 auch Port 20 freigegeben und weitergeleitet. Wenn ich nun allerdings versuche, mich mit dem aktiven FTP über FileZilla zu verbinden, bekomme ich folgende Meldungen:
    Code:
    Status:    Auflösen der IP-Adresse für nas.xxx.de
    Status:    Verbinde mit <Externe IP>:21...
    Status:    Verbindung hergestellt, warte auf Willkommensnachricht...
    Status:    Angemeldet
    Status:    Empfange Verzeichnisinhalt für "/Aufnahmen"...
    Befehl:    CWD /Aufnahmen
    Antwort:    250 CWD command successful.
    Befehl:    TYPE I
    Antwort:    200 Type set to I.
    Befehl:    PORT 192,168,0,11,198,128
    Antwort:    500 Invalid address rejected.
    Befehl:    PASV
    Antwort:    425 Can't open passive connection: No such file or directory.
    Fehler:    Verzeichnisinhalt konnte nicht empfangen werden
    
    Sieht für mich danach aus, als würde er sich doch über den passiven Modus verbinden wollen. Dabei habe ich in FileZilla unter Servermanager -> Übertragungs-Einstellungen -> Übertragungsmodus -> Aktiv eingestellt.
    
    Noch eine Idee?
    
    Ergänzung: Das ist das Ergebnis des OTR-Tests:
    
    15:05:33: Test startet
    15:05:33: Methode: ftp_put()
    15:05:33: Verbindungsaufbau zu nas.xxx.de:21 (Timeout=10 Sekunden)
    15:05:33: Verbindung hergestellt
    15:05:33: Anmeldung mit <Benutzername> war erfolgreich
    15:05:33: Passivmodus aus
    15:05:34: Quelldatei gefunden und bereit
    15:05:34: Ziel /Aufnahmen/OTR_TEST_2019-09-16-15-05-33-fput.txt
    15:05:34: Upload fehlgeschlagen
    15:05:34: Verbindung wird geschlossen
    15:05:34: Test beendet
    
    Ich versuche es wohl besser mit dem passiven FTP. Da funktioniert immerhin die Verbindung richtig.
    Die Seite ftptest.net liefert mir für meine Einstellungen das folgende Ergebnis: "Your server is working and assorted routers/firewalls have been correctly configured for plain basic FTP as performed by this test."
    Es muss also am OnlineTvRecorder liegen. Mit FileZilla funktioniert ja auch alles problemlos.
    
    @Admin Könnte ich bitte die Logfiles für eine Fehlerbehebung bekommen? Oder eine Antwort, wieso das hier nicht funktioniert?
    
    Hier nochmal ein Auschnitt des Logs von ftptest.net:
    
    ...       Command: USER <Username>
    
           Reply: 331 Password required for <Username>. 
    
           Command: PASS ********** 
    
           Reply: 230 User <Username> logged in, access restrictions apply. 
    
           Command: SYST 
    
           Reply: 215 UNIX Type: L8 
    
           Command: FEAT 
           Reply: 211- Extensions supported: 
    
           Reply:  AUTH TLS 
    
           Reply:  PBSZ 
    
           Reply:  PROT 
    
           Reply:  CCC 
    
           Reply:  SIZE 
    
           Reply:  MDTM 
    
           Reply:  REST STREAM 
    
           Reply:  MFMT 
    
           Reply:  TVFS 
    
           Reply:  MLST 
    
           Reply:  MLSD 
    
           Reply:  UTF8 
    
           Reply: 211 End. 
    
           Command: PWD 
    
           Reply: 257 "/" is current directory. 
    
           Status: Current path is / 
    
           Command: TYPE I 
    
           Reply: 200 Type set to I. 
    
           Command: PASV 
    
           Reply: 227 Entering Passive Mode (<Externe IP>,216,240) 
    
           Command: MLSD 
    
           Status: Data connection established. 
    
           Listing: modify=20190916141114;type=dir;unique=FD00UB7E;size=4096;UNIX.mode=0777;UNIX.owner=mschmale;UNIX.group=users; Aufnahmen 
    
    ...Reply: 150 Opening BINARY mode data connection for 'file list'. 
    
           Reply: 226 Transfer complete. 
    
           Status: Success
    Geändert von MCMUPPET (16.09.2019 um 16:53 Uhr) Grund: Beiträge zusammengeführt und Code Tag gesetzt

  6. #6
    Member
    Registriert seit
    Jul 2018
    Beiträge
    7
    Zitat Zitat von mschmale Beitrag anzeigen
    Code:
    Status:    Auflösen der IP-Adresse für nas.xxx.de
    Status:    Verbinde mit <Externe IP>:21...
    ...
    Befehl:    PORT 192,168,0,11,198,128
    Also, Dein fehlschlagender Test bzw. der Unterschied zwischen Filezilla und der FTP-Test-Seite kann unter anderem daran liegen, daß Dein Router (welcher? Fritzbox?) erkennt, daß Du mit der externen IP-Adresse auf das innenliegende Netzwerk zugreifen möchtest. Daher auch die unterschiedlichen IPs im Logfile.

    Das Problem mit passivem FTP ist, daß der Client (also der onlinetvrecorder.de-FTP-Versender) die Daten auf einen zusätzlichen, nicht einstellbaren, also zufälligen Port schicken möchte. Das heißt, Du müßtest alle Ports (über 1024) auf Deinen FTP-Server weiterleiten. Wenn Du das tun möchtest, oder Deinen FTP-Server als "exposed host" konfigurieren möchtest, dann kannst Du das im Router tun. Ich persönlich verzichte gerne darauf, dieses Scheunentor aufzumachen.

    Bei aktivem FTP macht der Server aktiv von sich aus eine ausgehende Datenverbindung zum onlinetvrecorder.de-FTP-Versender auf. Ausgehende Verbindungen sind oftmals wesentlich weniger ein Problem, als eingehende, wie z. B. oben beim passiven FTP.

  7. #7
    Member
    Registriert seit
    Apr 2018
    Beiträge
    9
    Zitat Zitat von cthom Beitrag anzeigen
    Also, Dein fehlschlagender Test bzw. der Unterschied zwischen Filezilla und der FTP-Test-Seite kann unter anderem daran liegen, daß Dein Router (welcher? Fritzbox?) erkennt, daß Du mit der externen IP-Adresse auf das innenliegende Netzwerk zugreifen möchtest. Daher auch die unterschiedlichen IPs im Logfile.

    Das Problem mit passivem FTP ist, daß der Client (also der onlinetvrecorder.de-FTP-Versender) die Daten auf einen zusätzlichen, nicht einstellbaren, also zufälligen Port schicken möchte. Das heißt, Du müßtest alle Ports (über 1024) auf Deinen FTP-Server weiterleiten. Wenn Du das tun möchtest, oder Deinen FTP-Server als "exposed host" konfigurieren möchtest, dann kannst Du das im Router tun. Ich persönlich verzichte gerne darauf, dieses Scheunentor aufzumachen.

    Bei aktivem FTP macht der Server aktiv von sich aus eine ausgehende Datenverbindung zum onlinetvrecorder.de-FTP-Versender auf. Ausgehende Verbindungen sind oftmals wesentlich weniger ein Problem, als eingehende, wie z. B. oben beim passiven FTP.
    Wenn ich passives FTP verwende, kann ich ja einen Port-Bereich in der DiskStation festlegen, der für die Datenübertragung genutzt werden soll. Diesen Portbereich habe ich auch freigegeben und weitergeleitet. Der Test vom OnlineTVRecorder schlägt ja auch nicht fehl. Die Datei landet beim passiven Modus fehlerfrei auf meinem NAS. Daher verstehe ich nicht, wo das Problem liegt. Wenn ich mit meinem Handy über das Handynetz versuche, eine Datei über den passiven Modus hochzuladen, funktioniert dies ebenfalls. Leider scheint der Moderator im Support-Chat nicht besonders motiviert zu sein. Vielleicht kann mir ja ein anderer Moderator beantworten, wieso das nicht geht? @MCMUPPET

    Ich würde ja auch gerne mal das aktive FTP ausprobieren, doch leider scheint das noch weniger zu funktionieren, was wohl an meiner komplizierten Netzwerkkonfiguration liegt. Also mit FileZilla kommt eine Verbindung im aktiven Modus nicht zustande, im passiven allerdings schon. Was könnte ich denn nun machen?

    UPDATE: Mit dem passiven FTP hat es anscheinend geklappt, obwohl mir der OTR anzeigt, dass es nicht geklappt hat! Wieso ist das so, @Admins? Dann scheint meine Konfiguration ja nicht falsch zu sein, nur eure Anzeige... ich versuche es nachher nochmal mit anderen Dateien. Hoffentlich kann ich das reproduzieren.

    Die Datei Pirates_of_the_Caribbean__Fremde_Gezeiten_19.09.15 _22-25_orf1_125_TVOON_DE.mpg.HQ.avi wurde erfolgreich gepusht und lässt sich problemlos abspielen. In der Übersicht des OTR hängt der Download allerdings wieder bei 3 Versuchen fest.
    Geändert von MCMUPPET (16.09.2019 um 17:46 Uhr) Grund: Fettschrift entfernt - Forenregeln beachten.

  8. #8
    Moderator
    Registriert seit
    Oct 2006
    Ort
    Where the wild things are
    Beiträge
    15.105
    Zitat Zitat von mschmale Beitrag anzeigen
    Leider scheint der Moderator im Support-Chat nicht besonders motiviert zu sein.
    Solch eine Aussage motiviert hier nicht tätig zu werden. Es gibt hier keinen Pflichtsupport und schon gar nicht innerhalb von Zeit X.

    MfG
    MCMUPPET

  9. #9
    Member
    Registriert seit
    Apr 2018
    Beiträge
    9
    Zitat Zitat von MCMUPPET Beitrag anzeigen
    So eine Aussage motiviert hier nicht tätig zu werden. Es gibt hier keinen Pflichtsupport und schon gar nicht innerhalb von Zeit X.

    MfG
    MCMUPPET
    Wenn ich höflich nach den Logfiles frage und dann nur "Nein." als Antwort kommt, dann ist das nicht besonders motiviert. Ich erwarte nicht, dass man mir die Konfiguration abnimmt, ein wenig Unterstützung kann man meiner Meinung nach schon erwarten. Insbesondere, da es ja anscheinend kein Problem auf meiner Seite ist und ich für die Downloads bezahlen muss. Ich hätte dem anderen Nutzer im Support-Chat auch nicht helfen müssen, aber das macht man eben, wenn man nett ist.

  10. #10
    Moderator
    Registriert seit
    Oct 2006
    Ort
    Where the wild things are
    Beiträge
    15.105
    Zitat Zitat von mschmale Beitrag anzeigen
    Wenn ich höflich nach den Logfiles frage und dann nur "Nein." als Antwort kommt, dann ist das nicht besonders motiviert.
    Hier ist niemand für Deine persönliche Motivation abgestellt.
    Zitat Zitat von mschmale Beitrag anzeigen
    Ich erwarte nicht, dass man mir die Konfiguration abnimmt, ein wenig Unterstützung kann man meiner Meinung nach schon erwarten. Insbesondere, da es ja anscheinend kein Problem auf meiner Seite ist und ich für die Downloads bezahlen muss.
    In den Trafficgebühren sind keine Supportgebühren enthalten. Du erwirbst mit einem Direktdownload in der RH kein Vorzugsrecht und auch kein Anrecht auf Support (in Zeit X).
    Zitat Zitat von mschmale Beitrag anzeigen
    Ich hätte dem anderen Nutzer im Support-Chat auch nicht helfen müssen, aber das macht man eben, wenn man nett ist.
    Da wir hier alle un-nett (= böse?) sind, verabschiede ich mich - aus Höflichkeit - von Dir.

    Back2Topic

    MfG
    MCMUPPET

Seite 1 von 2 12 LetzteLetzte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •