PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Otrdecoder Kde Gui Beta 0.0.3 [Download]



undefined
07.01.06, 23:28
Hallo Linuxer
Ich hatte über die feiertage Zeit mal wieder etwas in C++ zu Proggen und habe mir ein KDE Oberfläche für den Otrdecoder gebastelt.
Diese Version ist aber noch Beta also bitte nicht and den Hals springen wenn etwas schief geht.
Nutzung ohne jede gewähr ;)
Hier könnt ihr in Downloaden
http://developer.berlios.de/project/showfiles.php?group_id=2208

mfg undefined

Jagg
09.01.06, 07:56
Habs hier versucht auf Suse10 zu installieren, aber gettext fehlt bzw. es ist nur eine wohl zu alte Version zur Verfügung?!

[code:1].....
otrdecoderkdegui: Hägt ab von: gettext (>= 0.14.5) aber 0.14.3-6 wird installiert werden[/code:1]

undefined
09.01.06, 15:02
Ich habe eben eine Neue Version hinaufgeladen, mit dieser dürfte die Meldung nicht mehr kommen.

Jagg
09.01.06, 20:10
Ja, jetzt klappt es wunderbar. Sieht auch gut aus das Programm :wink:

undefined
10.01.06, 18:56
[code:1]Sieht auch gut aus das Programm..[/code:1]
Das Kde Design gefällt mir unter Linux im Moment auch am besten. :D

So - jetzt auf 0.0.5 gesetzt und paar kleinere Bugs bei der Prozess Anzeige entfernt. Die Anwendung läuft auch so weit Stabil. Ich hatte bisher auch noch keine kaputten Files. Ich finde auch das der otrdecoder unter Linux besser Funktioniert wie die Windows Version.

Menno
10.01.06, 19:08
Original von undefined

Ich finde auch das der otrdecoder unter Linux besser Funktioniert wie die Windows Version.

Kloar, unter Linux gibts auch sowas wie nen runtime error nicht ;)

Columbo0815
11.01.06, 16:16
Hallo,

beim kompilieren der Version 0.0.5 mit Debian Sarge (Kde 3.3) erhalte ich folgende Fehlermeldung nach dem Ausführen von make:



make[3]: Entering directory `/usr/src/otrdecoderkdegui-0.0.5/src'
/usr/bin/kconfig_compiler ./otrdecoderSettings.kcfg ./otrdecoderSettings.kcfgc; ret=$?; \
if test "$ret" != 0; then rm -f otrdecoderSettings.h ; exit $ret ; fi
kconfig_compiler: ERROR: Singleton class can not use filename as argument.
make[3]: *** [otrdecoderSettings.h] Fehler 1
make[3]: Leaving directory `/usr/src/otrdecoderkdegui-0.0.5/src'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/usr/src/otrdecoderkdegui-0.0.5/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/usr/src/otrdecoderkdegui-0.0.5'
make: *** [all] Fehler 2


Beim Ausführen von "./configure --prefix=/usr" erhalte ich keine Fehlermeldung.

Wie kann ich den Fehler beheben?
Gruß und Danke

undefined
11.01.06, 20:15
Diese Anwendung wurde mit KDE 3.4.3 erstellt.
Es kann gut sein das die Klasse KConfigSkeleton in der Alten Version dies noch nicht unterstützt. Leider habe ich kein Betriebsystem auf dem eine Version älter als 3.4.1 läuft. Daher kann ich das Problem für dich im Moment nicht fixen. Ich werde die Tage mal bei einem Kumpel nachsehen dort läuft ein Kde dieser version.
mfg undefined

Columbo0815
12.01.06, 09:03
Super, vielen Dank! Leider habe ich von programmieren überhaupt keine Ahnung. Wenn ich dir beim beheben des "Fehlers" in einer anderen Weise behilflich sein kann gib Bescheid.

Gruß

undefined
13.01.06, 18:07
So, Für Debian gibt es jetzt ein Extra Sourcen paket und ein *.deb erstellt auf Debian Sarge 3.1 mit KDE: 3.3.2
http://developer.berlios.de/project/showfiles.php?group_id=2208
mfg undefined

Columbo0815
15.01.06, 10:16
Hallo,

ich habe die Sourcen für Debian getestet. Ich konnte mir daraus ein .deb bauen und dieses installieren. Funktioniert einwandfrei.

Vielen Dank!

undefined
15.01.06, 16:21
Fein fein - gut zu hören das es auch auf ältern KDE Versionen funktioniert.
mfg undefined